Mail delivery delayed

Incident Report for Kundo

Resolved

This incident has been resolved.
Posted May 25, 2026 - 15:56 CEST

Monitoring

Mailgun has implemented a fix, and we are seeing an increased volume of sent emails.
Posted May 25, 2026 - 15:07 CEST

Identified

Our subcontractor, MailGun, is currently having a problem with the delivery of mail. See https://status.mailgun.com/ for more information
Posted May 25, 2026 - 14:24 CEST
This incident affected: Mail.