Slow data delivery from database

Incident Report for Kundo

Postmortem

Incident summary – 2026-05-13

Between 11:01 and 13:41 CET, Kundo experienced two related periods of degraded service.

The first affected platform availability between 11:01 and 11:36, where slow or unavailable response times were observed. This was caused by a database migration running as part of a scheduled deployment that placed unexpected load on our database. The migration was stopped and the deployment was rolled back, restoring normal response times at 11:29.

The second period affected data delivery between 11:56 and 13:41, where users were not seeing updates to tickets and other changes. This was caused by a lag on our read replica database catching up after the migration was stopped. The issue was resolved by temporarily routing read traffic to the primary database while the replica recovered.

No data was lost. We have reviewed our deployment and migration routines and are implementing additional safeguards to prevent similar incidents in the future.

Posted May 18, 2026 - 15:55 CEST

Resolved

This incident has been resolved.
Posted May 13, 2026 - 13:41 CEST

Update

The issue seems to be resolved, but we continue to monitor the situation.
Posted May 13, 2026 - 12:10 CEST

Update

We are seeing an improvement in data delivery.
Posted May 13, 2026 - 12:03 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 12:01 CEST

Update

A fix has been identified and beeing implemented.
Posted May 13, 2026 - 11:56 CEST

Identified

Updates to the database is not displayed to users. After the previous incident, our databases are working to replicate information written to the databases.

This results in users not seeing new tickets, changes to tickets and similar actions.

We are investigating the situation.
Posted May 13, 2026 - 11:52 CEST
This incident affected: Kundo and Dashboard.