Delays in sending emails in Kundo Mail
Incident Report for Kundo
Resolved
The issue has now been resolved at our provider.
Posted Jun 09, 2022 - 18:11 CEST
Monitoring
The issue at our provider has been mostly resolved and outgoing emails are being sent normally. We continue to monitor the situation.
Posted Jun 09, 2022 - 17:18 CEST
Identified
There are currently delays when sending emails in Kundo Mail. There are no problems in receiving emails in Kundo. Other Kundo products are not affected. One of our providers is experiencing a technical issue and are working to resolve it. We will continually update until the situation is solved.

All emails will be sent automatically when the problem is resolved.
Posted Jun 09, 2022 - 14:53 CEST
This incident affected: Mail.