Slow dashboard
Incident Report for Kundo
Postmortem

Slow dashboard

We apologize for any inconvenience caused by this incident. A summary of the events and measures taken follows.

Summary

An issue related to one of our cache services resulted i degraded performance in our dashboard.

Timeline (in CET)

08:08 First indication of a slower dashboard for a few of our users

08:23 We notice more affected users and started our incident process

~08:30 We removed jobs from our queues to reduce the load on the systems

08:37 We’ve identified the issue with caching and scaled up our systems to handle the additional load

08:45 All systems are operating as normal

What happened?

We had an issue with one of our caching services which caused an increased load on other systems - making the dashboard slower than usual.

Actions to mitigate impact of incidents like these in future

  • We’ve made multiple improvements to the caching service
  • Improve our monitoring
Posted Nov 02, 2023 - 14:41 CET

Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 08:54 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2023 - 08:46 CEST
Identified
An issue with the autoscaling of the Kundo infrastructure was identified and a fix is being implemented
Posted Oct 18, 2023 - 08:45 CEST
Investigating
We are currently investigating this issue.
Posted Oct 18, 2023 - 08:35 CEST
This incident affected: Kundo, Dashboard, Mail, Chat, Calls, Forum, Knowledge and Help Center, Statistics and Social media channels (Facebook, Instagram).